Railsをインストールするとnokogiriのコンパイルでエラーになる

CentOS 6.7にRailsをインストールしようとしたら、nokogiriというgemがコンパイルできずにエラーになりました。

(対策)
こちらのサイトを参考にしました。

$ sudo yum -y install libxml2 libxslt libxml2-devel libxslt-devel
$ sudo `which gem` install nokogiri -- --use-system-libraries --no-ri --no-rdoc
$ sudo `which gem` install rails --no-ri --no-rdoc
Linuxプログラミング環境インストール物語 © 2016 Frontier Theme